Web Interfaces of PROSUME
Francesco Arcarese 7e50298209 updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
..
docs updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
src updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
tests updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
.gitignore updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
.scrutinizer.yml updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
.travis.yml updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
CHANGELOG.md updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
CONTRIBUTING.md updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
LICENSE updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
README.md updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
composer.json updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
phpunit.php updated LICENSE and README + upload of the whole project files and sql dump 2 years ago
phpunit.xml.dist updated LICENSE and README + upload of the whole project files and sql dump 2 years ago

README.md

Aura.Intl

The Aura.Intl package provides internationalization (I18N) tools, specifically package-oriented per-locale message translation.

Installation and Autoloading

This package is installable and PSR-4 autoloadable via Composer as aura/intl.

Alternatively, download a release, or clone this repository, then map the Aura\Intl\ namespace to the package src/ directory.

Dependencies

This package requires PHP 5.6 or later; it has been tested on PHP 5.6, 7.0 and HHVM. We recommend using the latest available version of PHP as a matter of principle.

Aura library packages may sometimes depend on external interfaces, but never on external implementations. This allows compliance with community standards without compromising flexibility. For specifics, please examine the package composer.json file.

Quality

Scrutinizer Code Quality Code Coverage Build Status

This project adheres to Semantic Versioning.

To run the unit tests at the command line, issue composer install and then phpunit at the package root. This requires Composer to be available as composer, and PHPUnit to be available as phpunit.

This package attempts to comply with PSR-1, PSR-2, and PSR-4. If you notice compliance oversights, please send a patch via pull request.

Community

To ask questions, provide feedback, or otherwise communicate with other Aura users, please join our Google Group, follow @auraphp, or chat with us on Freenode in the #auraphp channel.

Documentation

This package is fully documented here.