Browse Source

use npm packages

Kieran Gibb 2 years ago
parent
commit
0aab3717ed
No known key found for this signature in database
2 changed files with 40 additions and 73 deletions
  1. 4
    4
      package.json
  2. 36
    69
      yarn.lock

+ 4
- 4
package.json View File

@@ -13,10 +13,10 @@
13 13
   "license": "AGPL-3.0-or-later",
14 14
   "dependencies": {
15 15
     "call-me-maybe": "^1.0.1",
16
-    "cobox-config": "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-config.git",
17
-    "cobox-constants": "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-constants.git",
18
-    "cobox-crypto": "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-crypto.git",
19
-    "cobox-group": "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-group.git",
16
+    "cobox-config": "^2.0.0",
17
+    "cobox-constants": "^1.0.0",
18
+    "cobox-crypto": "^1.1.0",
19
+    "cobox-group": "^2.0.0",
20 20
     "debug": "^4.1.1",
21 21
     "thunky": "^1.1.0"
22 22
   },

+ 36
- 69
yarn.lock View File

@@ -279,9 +279,10 @@ circular-append-file@^1.0.1:
279 279
   dependencies:
280 280
     multistream "^2.1.0"
281 281
 
282
-"cobox-config@git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-config.git":
283
-  version "1.0.2"
284
-  resolved "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-config.git#80233430f411b3cedf137aef42e46be08c88a276"
282
+cobox-config@^2.0.0:
283
+  version "2.0.0"
284
+  resolved "https://registry.yarnpkg.com/cobox-config/-/cobox-config-2.0.0.tgz#6eed6f2b2fb5384d4fa78caf1fcd02961f7810ba"
285
+  integrity sha512-y926lU+0omS571LUrIDsUPAxNQNIkGlb3xLRdKf9uCqOLDnPz/p2qT2zdtb+5IGsYeIgHEcI7MBFmXvjvSCXFQ==
285 286
   dependencies:
286 287
     cobox-crypto "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-crypto.git"
287 288
     debug "^4.1.1"
@@ -291,12 +292,23 @@ circular-append-file@^1.0.1:
291 292
     pino "^5.13.2"
292 293
     urlsafe-base64 "^1.0.0"
293 294
 
294
-"cobox-constants@git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-constants.git":
295
+cobox-constants@^1.0.0:
295 296
   version "1.0.0"
296
-  resolved "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-constants.git#1261021d76e244fa7c4b594932f7c3e676b905f2"
297
+  resolved "https://registry.yarnpkg.com/cobox-constants/-/cobox-constants-1.0.0.tgz#e8e5cdc2407658ed0950ce3de092c8bfa4654110"
298
+  integrity sha512-npUyD3yEFkURL2g01rBpt01xQn4aNROah7sK4BTuabVE06BC/28Vd6O80HUar73+VpBYk69gs0QP8T+NOnKF7w==
297 299
   dependencies:
298 300
     os "^0.1.1"
299 301
 
302
+cobox-crypto@^1.1.0:
303
+  version "1.1.0"
304
+  resolved "https://registry.yarnpkg.com/cobox-crypto/-/cobox-crypto-1.1.0.tgz#02b203ba1d2c71418275099161c302d0094b3af4"
305
+  integrity sha512-3PjQNzJSrXPRD9KCp2G2xhVdv+Bga/FgSbYa9sedZfXdkRHfqZO/MGoske7NBtCxVHbxG5ruCq0Rx0ZbJry7bw==
306
+  dependencies:
307
+    assert "^2.0.0"
308
+    buffer-alloc-unsafe "^1.1.0"
309
+    hypercore-crypto "^1.0.0"
310
+    sodium-native "^2.4.2"
311
+
300 312
 "cobox-crypto@git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-crypto.git":
301 313
   version "1.0.3"
302 314
   resolved "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-crypto.git#7d5aa64c9300ef73df638764be0828e50a22df48"
@@ -306,17 +318,17 @@ circular-append-file@^1.0.1:
306 318
     hypercore-crypto "^1.0.0"
307 319
     sodium-native "^2.4.2"
308 320
 
309
-"cobox-group@git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-group.git":
310
-  version "1.0.1"
311
-  resolved "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-group.git#0d87e38a756e2871c8d9a5ef56667a3e7b8cb828"
321
+cobox-group@^2.0.0:
322
+  version "2.0.0"
323
+  resolved "https://registry.yarnpkg.com/cobox-group/-/cobox-group-2.0.0.tgz#f98449442e966140256d9fcba6a75f0344e2c39f"
324
+  integrity sha512-e5Rwu9HQKTAG52z/FuklBRB96J9gqX8nXj6xGOhyWjnfnvrfQoS4QgqtALQobSREFHkKc+QoTWEQJbT3knoA/w==
312 325
   dependencies:
313 326
     assert "^2.0.0"
314
-    cobox-config "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-config.git"
315
-    cobox-crypto "git+ssh://git@ledger-git.dyne.org:2240/CoBox/cobox-crypto.git"
327
+    cobox-config "^2.0.0"
328
+    cobox-crypto "^1.1.0"
316 329
     hypercore "^7.5.1"
317 330
     kappa-core "^4.0.0"
318
-    kappa-drive "git+ssh://git@ledger-git.dyne.org:2240/CoBox/kappa-drive.git"
319
-    kappa-drive-mount "^1.1.0"
331
+    kappa-drive "^1.1.0"
320 332
     kappa-view-query "^2.0.6"
321 333
     level "^5.0.1"
322 334
     memdb "^1.3.1"
@@ -719,35 +731,6 @@ functional-red-black-tree@^1.0.1:
719 731
   resolved "https://registry.yarnpkg.com/functional-red-black-tree/-/functional-red-black-tree-1.0.1.tgz#1b0ab3bd553b2a0d6399d29c0e3ea0b252078327"
720 732
   integrity sha1-GwqzvVU7Kg1jmdKcDj6gslIHgyc=
721 733
 
722
-fuse-native@^1.1.0:
723
-  version "1.1.2"
724
-  resolved "https://registry.yarnpkg.com/fuse-native/-/fuse-native-1.1.2.tgz#108dafcc397c3a83ff62a93154d97d14fdeaee2b"
725
-  integrity sha512-+InNbU/xodg6wUQvqcZaxL070/si0TyinxlnzyHm0XsMffgy7VOz7wi6+jfgOtdhfUtJs9tvY4zHu1/UfYIRxw==
726
-  dependencies:
727
-    fuse-shared-library "^1.0.1"
728
-    nan "^2.13.2"
729
-    napi-macros "^1.8.2"
730
-    node-gyp-build "^3.2.2"
731
-    xtend "^4.0.1"
732
-
733
-fuse-shared-library-darwin@^1.0.0:
734
-  version "1.0.1"
735
-  resolved "https://registry.yarnpkg.com/fuse-shared-library-darwin/-/fuse-shared-library-darwin-1.0.1.tgz#05f4ef21c04b4cbbdd963eb800f55b28ecf16443"
736
-  integrity sha512-thQh0BsvIK93pPV/8a25HmIzxmmGKKedw3KZTxy/4Y7D+Rix/3bT0EcCQ4Ll+U1EkDGy+1Px18B1PsHu4J+z7w==
737
-
738
-fuse-shared-library-linux@^1.0.0:
739
-  version "1.0.1"
740
-  resolved "https://registry.yarnpkg.com/fuse-shared-library-linux/-/fuse-shared-library-linux-1.0.1.tgz#fd182f0c5e8e46f5c9b0a7639a9db7d48b25c8d5"
741
-  integrity sha512-07MQRSobrBKwW4D7oKm0gM2TwgvZWb+gC08JdiYDG4KBTncxk9ssqEDiDMKll8hpseZufsY2w1yc/feOu2DPmQ==
742
-
743
-fuse-shared-library@^1.0.1:
744
-  version "1.0.1"
745
-  resolved "https://registry.yarnpkg.com/fuse-shared-library/-/fuse-shared-library-1.0.1.tgz#56ccbd72fc01f901b1248ee4d6c0446074e3321c"
746
-  integrity sha512-B28UMu1yKCK+Cr2UnC5ykAZQhw9arcPcvwzQyoo3jjKzdy1a8OBxXHtf5UlRVjVw//JIPKFgW10AfTl0TOi6SA==
747
-  dependencies:
748
-    fuse-shared-library-darwin "^1.0.0"
749
-    fuse-shared-library-linux "^1.0.0"
750
-
751 734
 generate-function@^2.0.0:
752 735
   version "2.3.1"
753 736
   resolved "https://registry.yarnpkg.com/generate-function/-/generate-function-2.3.1.tgz#f069617690c10c868e73b8465746764f97c3479f"
@@ -861,15 +844,6 @@ hypercore@^7.0.0, hypercore@^7.2.2, hypercore@^7.4.0, hypercore@^7.5.1:
861 844
   optionalDependencies:
862 845
     fd-lock "^1.0.2"
863 846
 
864
-hyperdrive-fuse@^1.1.2:
865
-  version "1.1.2"
866
-  resolved "https://registry.yarnpkg.com/hyperdrive-fuse/-/hyperdrive-fuse-1.1.2.tgz#2b4ab87e1d33036d1a21b904cf1474f4add2a308"
867
-  integrity sha512-LF38svTj0tkfrEbi2IpJHa6O33Pti8awGbqujlRZhX73CIQC40g1svwHlxkGNb3ByD7sf1GHUVNOAp9qyWHx/w==
868
-  dependencies:
869
-    dat-encoding "^5.0.1"
870
-    filesystem-constants "^1.0.0"
871
-    fuse-native "^1.1.0"
872
-
873 847
 hyperdrive-schemas@^0.12.0:
874 848
   version "0.12.1"
875 849
   resolved "https://registry.yarnpkg.com/hyperdrive-schemas/-/hyperdrive-schemas-0.12.1.tgz#1e95ad3b2610a384ea7e2781a0401058400bdf07"
@@ -1101,21 +1075,13 @@ kappa-core@^4.0.0:
1101 1075
     multifeed "^4.0.0"
1102 1076
     multifeed-index "^3.3.2"
1103 1077
 
1104
-kappa-drive-mount@^1.1.0:
1078
+kappa-drive@^1.1.0:
1105 1079
   version "1.1.0"
1106
-  resolved "https://registry.yarnpkg.com/kappa-drive-mount/-/kappa-drive-mount-1.1.0.tgz#2608cbdc3f99d98e1f87b309d5943b6a279f92b2"
1107
-  integrity sha512-tc/KmcE2234Gwxj3j80QTq1RSh6FPm/w1T9T+a9HO99VyxdScjGw3He9rtlaNm//c48oQWyPJydAyT4iGMqtxQ==
1108
-  dependencies:
1109
-    debug "^4.1.1"
1110
-    hyperdrive-fuse "^1.1.2"
1111
-    mkdirp "^0.5.1"
1112
-    rimraf "^2.6.3"
1113
-
1114
-"kappa-drive@git+ssh://git@ledger-git.dyne.org:2240/CoBox/kappa-drive.git":
1115
-  version "1.0.0"
1116
-  resolved "git+ssh://git@ledger-git.dyne.org:2240/CoBox/kappa-drive.git#e217dfd92f4dedc555b1ff9c7a4e28eb810e592f"
1080
+  resolved "https://registry.yarnpkg.com/kappa-drive/-/kappa-drive-1.1.0.tgz#a0aef6d3630bd20704de8c6131842264e79b92c9"
1081
+  integrity sha512-3jM13DAgF4K3QdFsPDdfQB8mcXK4joDWxT4Acs1+WYkAj3beNbh1/fFfairu2pLUBfW9V7QIk0aBIDELc2E5NQ==
1117 1082
   dependencies:
1118 1083
     assert "^2.0.0"
1084
+    call-me-maybe "^1.0.1"
1119 1085
     collect-stream "^1.2.1"
1120 1086
     contains-path "^1.0.0"
1121 1087
     corestore "^2.0.0"
@@ -1126,7 +1092,7 @@ kappa-drive-mount@^1.1.0:
1126 1092
     hyperdrive "^10.3.2"
1127 1093
     hyperswarm "^2.1.0"
1128 1094
     kappa-core "^4.0.0"
1129
-    kappa-view-kv "github:kappa-db/kappa-view-kv#callback-state-as-buffers"
1095
+    kappa-view-kv "^2.0.2"
1130 1096
     level "^5.0.1"
1131 1097
     memdb "^1.3.1"
1132 1098
     minimist "^1.2.0"
@@ -1137,9 +1103,10 @@ kappa-drive-mount@^1.1.0:
1137 1103
     through2 "^3.0.1"
1138 1104
     unixify "^1.0.0"
1139 1105
 
1140
-"kappa-view-kv@github:kappa-db/kappa-view-kv#callback-state-as-buffers":
1141
-  version "2.0.1"
1142
-  resolved "https://codeload.github.com/kappa-db/kappa-view-kv/tar.gz/ddfd1dd2bdd3fbda8b9cda84503f445d46d73be2"
1106
+kappa-view-kv@^2.0.2:
1107
+  version "2.0.2"
1108
+  resolved "https://registry.yarnpkg.com/kappa-view-kv/-/kappa-view-kv-2.0.2.tgz#95c044b6652bae265423fbb03787c213a09865a4"
1109
+  integrity sha512-FfkzFlLnAFdZekYqHDz9vGAOyHcYMjtAIQE0Iqdry+rotPnWHXjpDIEgVCo+Pxa0BsphmREN4qUt2bh379bhuQ==
1143 1110
   dependencies:
1144 1111
     through2 "^2.0.3"
1145 1112
     unordered-materialized-kv "^1.2.1"
@@ -1471,7 +1438,7 @@ mutexify@^1.2.0:
1471 1438
   resolved "https://registry.yarnpkg.com/mutexify/-/mutexify-1.2.0.tgz#45597975a2b035f56dcf61ff15cc8d73c28e7639"
1472 1439
   integrity sha512-oprzxd2zhfrJqEuB98qc1dRMMonClBQ57UPDjnbcrah4orEMTq1jq3+AcdFe5ePzdbJXI7zmdhfftIdMnhYFoQ==
1473 1440
 
1474
-nan@^2.13.2, nan@^2.14.0:
1441
+nan@^2.14.0:
1475 1442
   version "2.14.0"
1476 1443
   resolved "https://registry.yarnpkg.com/nan/-/nan-2.14.0.tgz#7818f722027b2459a86f0295d434d1fc2336c52c"
1477 1444
   integrity sha512-INOFj37C7k3AfaNTtX8RhsTw7qRy7eLET14cROi9+5HAVbbHuIWUHEauBv5qT4Av2tWasiTY1Jw6puUNqRJXQg==
@@ -1516,7 +1483,7 @@ network-address@^1.1.2:
1516 1483
   resolved "https://registry.yarnpkg.com/network-address/-/network-address-1.1.2.tgz#4aa7bfd43f03f0b81c9702b13d6a858ddb326f3e"
1517 1484
   integrity sha1-Sqe/1D8D8LgclwKxPWqFjdsybz4=
1518 1485
 
1519
-node-gyp-build@^3.2.2, node-gyp-build@^3.5.0, node-gyp-build@^3.8.0:
1486
+node-gyp-build@^3.5.0, node-gyp-build@^3.8.0:
1520 1487
   version "3.9.0"
1521 1488
   resolved "https://registry.yarnpkg.com/node-gyp-build/-/node-gyp-build-3.9.0.tgz#53a350187dd4d5276750da21605d1cb681d09e25"
1522 1489
   integrity sha512-zLcTg6P4AbcHPq465ZMFNXx7XpKKJh+7kkN699NiQWisR2uWYOWNWqRHAmbnmKiL4e9aLSlmy5U7rEMUXV59+A==
@@ -2309,7 +2276,7 @@ xsalsa20@^1.0.0:
2309 2276
   resolved "https://registry.yarnpkg.com/xsalsa20/-/xsalsa20-1.0.2.tgz#46cc53439d543d88782e42dfada5c5a69ab6314d"
2310 2277
   integrity sha512-g1DFmZ5JJ9Qzvt4dMw6m9IydqoCSP381ucU5zm46Owbk3bwmqAr8eEJirOPc7PrXRn45drzOpAyDp8jsnoyXyw==
2311 2278
 
2312
-xtend@^4.0.0, xtend@^4.0.1, xtend@^4.0.2, xtend@~4.0.0, xtend@~4.0.1:
2279
+xtend@^4.0.0, xtend@^4.0.2, xtend@~4.0.0, xtend@~4.0.1:
2313 2280
   version "4.0.2"
2314 2281
   resolved "https://registry.yarnpkg.com/xtend/-/xtend-4.0.2.tgz#bb72779f5fa465186b1f438f674fa347fdb5db54"
2315 2282
   integrity sha512-LKYU1iAXJXUgAXn9URjiu+MWhyUXHsvfp7mcuYm9dSUKK0/CjtrUwFAxD82/mCWbtLsGjFIad0wIsod4zrTAEQ==